纵有疾风起
人生不言弃

web工程导入新环境的注意事项

问题一:The type java.lang.Object cannot be resolved.

解决办法:

当你在Eclipse引用不同版本JDK工程时会发生该问题。由于你开发环境中应用了多个版本的JDK 或JRE导致的。Eclipse会按照最初的开发环境默认选择对应的Jre。如Eclipse上有jdk1.4开发的环境工程,当你在引入高版本jdk1.6开发的工程时,以上问题就出现了。

问题解决的方案如下:

进入window\preferences\java\Installed JREs 
按Add –> Browse…—>选择jre安装路劲(我的jre路径是D:\Program Files\Java\jre1.6.0_02)—>OK
找到你的工程右键点击Properties选项 出现对话框后 选择右边的Libraries选项卡 —> 单击Add 了Library…—>

选择Jre System Library… —> Next—>选择Alternate Jre 下的对应版本jre –> Finish —> Ok

以上问题就可解决。

除此之外,android版本的变化也会引起类似问题。

 

问题二:去掉Myeclipse对JS等文件的验证

选择MyEclipse—>validation—>Excluded Resource下找到不需要验证的文件或者文件夹

在MyEclipse菜单栏window —>preferences —>myeclipse —>validation —>javascript validator for Js    files 把Bulid 复选框的勾去掉 就可以了

 

问题三:Project编码为UTF-8

Window->Preferences中,General->Workspace,将Text  file encoding 设置为other->UTF-8

在MyEclipse->Files& Editors中,将CSS,DTD,HTML,JAVASCRIPT,JSP,XML等文件格式都设置为UTF-8

这样,工程中的所有文件都会以UTF-8的格式保存,就不会出现保存不了的问题了。

 

问题四:Can’t load AMD 64-bit .dll on a IA 32-bit platform

表示系统是64位的,但jdk是32位的。

在CMD输入:java -version

看第三行内容是否包含“64”,如果不包含,说明你的JAVA_HOME的地址指向为32位的JDK,下载一个64的JDK安装,修改JAVA_HOME

tomcat和jdk都必须是64位的

文章转载于:https://www.cnblogs.com/kxdblog/p/4366282.html

原著是一个有趣的人,若有侵权,请通知删除

未经允许不得转载:起风网 » web工程导入新环境的注意事项

分享到: 生成海报

评论 抢沙发

评论前必须登录!

立即登录   注册

切换注册

登录

忘记密码 ?

切换登录

注册

我们将发送一封验证邮件至你的邮箱, 请正确填写以完成账号注册和激活